Service Web application (UI) seems to be down

Major Incident Web application (UI) Contact tracking and interactions
2025-01-23 16:09 CET · 2 hours, 50 minutes

Update

Update

Between 16h and 19h we experienced some problems with our platform.
The issue has been resolved! We will continue monitoring, to make sure there will be no more problems.
Our apologies for the inconvenience!

January 23, 2025 · 19:59 CET
Monitoring

The issue seems to be resolved, but we are still monitoring to make sure everything works as it should. If you are still experiencing difficulties, please let us know at support@flexmail.be.

January 23, 2025 · 17:00 CET
Issue

At the moment it is not possible to log in to Flexmail. We are investigating the issue and will keep you updated soon.

January 23, 2025 · 16:09 CET

← Back