Login problem

Major Incident Web application (UI)
2020-07-14 14:15 CEST · 2 hours, 2 minutes

Update

Resolved

The issue regarding the login has been resolved!
If you are still experiencing difficulties, please let us know at support@flexmail.be.
Our apologies for the inconvenience!

November 4, 2021 · 16:24 CEST
Update

Our team believes we’ve identified a root cause and are working on a fix.
Thank you for your patience!

November 4, 2021 · 16:24 CEST
Update

Unfortunately there is still an issue with logging in to the account. Our team is still investigating the issue. We will keep you updated as soon as we know more.

November 4, 2021 · 16:24 CEST
Issue

You may experience some difficulties with logging in to the account. We will do our best to solve this as soon as possible.
Updates will follow on this page.

November 4, 2021 · 16:24 CEST

← Back