Problem accessing the application
Minor Incident
Web application (UI)
2025-07-31 14:27 CEST
· 36 minutes
Update
Resolved
July 31, 2025 · 16:26 CEST
The issue has been resolved! We will continue monitoring to make sure there will be no more problems.
Monitoring
July 31, 2025 · 15:04 CEST
The issue seems to be resolved, but we are still monitoring to make sure everything works as it should. If you are still experiencing difficulties, please let us know at support@flexmail.be
Issue
July 31, 2025 · 14:36 CEST
At the moment it is not possible to log in to Flexmail.
We are currently investigating and will keep you updated.
← Back