Problem accessing the application
Major Incident
Web application (UI)
2025-10-09 15:14 CEST
· 11 minutes
Update
Resolved
October 9, 2025 · 15:25 CEST
The issue has been resolved! We will continue monitoring to make sure there will be no more problems.
Issue
October 9, 2025 · 15:14 CEST
At the moment it is not possible to log in to Flexmail.
We are currently investigating and will keep you updated.
← Back