Support Service Disruption Notice
Minor Incident
Helpdesk
2025-10-20 10:20 CEST
· 1 hour, 28 minutes
Update
Resolved
October 20, 2025 · 11:31 CEST
It appears our our helpdesk software provider’s systems are back operational. We’ll keep monitoring the situation on our end and will re-escalate if needed.
Issue
October 20, 2025 · 09:30 CEST
We are currently experiencing technical issues with our helpdesk software provider. As a result, there may be delays in responses via email and chat, and phone support might also be impacted.
Our team is in close contact with the provider and working to resolve the issue as quickly as possible.
We sincerely apologize for the inconvenience and appreciate your patience.
← Back