Login issues

Major Incident Web application (UI)
2020-10-08 13:47 CEST · 20 minutes, 26 seconds

Update

Resolved

The issue regarding the login has been resolved! If you are still experiencing difficulties, please let us know at support@flexmail.be. Our apologies for the inconvenience!

October 8, 2020 · 14:08 CEST
Issue

At the moment it is not possible to log in to Flexmail. We are investigating the issue and will keep you updated soon.

October 8, 2020 · 13:48 CEST

← Back