Manage campaign page keeps loading
Minor Incident
Web application (UI)
2026-02-12 14:29 CET
· 33 minutes
Update
Resolved
February 12, 2026 · 15:00 CET
The issue has been resolved!
If you are still experiencing difficulties accessing your campaigns, please let us know at support@flexmail.be.
Our apologies for the inconvenience!
Issue
February 12, 2026 · 14:39 CET
At the moment the “Manage campaigns” page keeps loading. We will do our best to resolve this as soon as possible.
← Back