Manage Campaigns is loading slow

Minor Incident Web application (UI)
2020-12-01 09:30 CEST · 1 hour, 15 minutes

Update

Resolved

Between 9.30 and 10.45 we experienced some performance issues with ‘Manage campaigns’ page.

The issue has been resolved!

We will continue monitoring, to make sure there will be no more problems. Our apologies for the inconvenience!

December 1, 2020 · 10:50 CEST
Issue

It was brought to our attention the ‘Manage Campaigns’ screen is loading slowly at the moment. We will do our best to solve this as soon as possible.

Updates will follow on this page.

December 1, 2020 · 10:27 CEST

← Back