Saving Email builder messages

Minor Incident Web application (UI)
2026-09-23 14:10 CEST · 1 hour, 19 minutes

Update

Resolved

Our technical team was able to resolve the issue. Still having trouble? Let us know on support@flexmail.be.

Our apologies for the inconvenience!

September 23, 2026 · 15:05 CEST
Investigating

We’re currently investigating reports of user not able to save Email builder messages.

September 23, 2026 · 14:29 CEST

← Back