Web Application down

Major Incident Web application (UI) Contact tracking and interactions Website
2019-11-20 09:13 CEST · 23 minutes, 6 seconds

Update

Resolved

The issue has been resolved! We will continue monitoring, to make sure there will be no more problems.

Our apologies for the inconvenience!

November 20, 2019 · 09:36 CEST
Issue

At the moment it is not possible to log in to Flexmail. We will do our best to solve this as soon as possible. Updates will follow on this page.

November 20, 2019 · 09:27 CEST

← Back