Sending of campaigns is delayed

Minor Incident Email sending / deliverability (MTA)
2019-12-12 13:45 CEST · 29 minutes

Update

Resolved

The issue seems to be resolved, but we are still investigating what caused this problem.
Our apologies for the inconvenience!

If you are still experiencing difficulties, please let us know at support@flexmail.be.

November 4, 2021 · 16:24 CEST
Issue

At the moment sending of campaigns is delayed. We will do our best to solve this as soon as possible.

Updates will follow on this page.

November 4, 2021 · 16:24 CEST

← Back