Login issue

Minor Incident Web application (UI)
2021-12-07 15:59 CEST · 1 hour, 4 minutes, 39 seconds

Update

Resolved

The issue seems to be resolved. If you are still experiencing difficulties, please let us know at support@flexmail.be.

Our apologies for the inconvenience!

December 7, 2021 · 17:03 CEST
Monitoring

The issue seems to be resolved, but we are still monitoring to make sure everything works as it should. If you are still experiencing difficulties, please let us know at support@flexmail.be.

December 7, 2021 · 16:37 CEST
Issue

You may experience some difficulties with logging in to your Flexmail account .
Updates will follow on this page.

December 7, 2021 · 16:02 CEST

← Back