Delay possible while sending campaigns

Minor Incident Email sending / deliverability (MTA)
2022-06-02 15:24 CEST · 1 hour, 6 minutes

Update

Resolved

The root cause has been found and the issue has been resolved. All queued campaigns have been processed and sent.

If you still experience any issues please contact us at support@flexmail.eu

Our apologies for the inconvenience!

June 2, 2022 · 16:52 CEST
Issue

There can be a delay while sending campaigns. We are investigating the issue at the moment and will keep you updated!

June 2, 2022 · 15:28 CEST

← Back